Back to overview
Degraded

Investigating an issue where payments are not remaining in pending status as expected

Apr 5, 2026 at 3:00pm UTC
Affected services
API

Resolved
Apr 5, 2026 at 4:26pm UTC

We identified an issue affecting payment status updates and ledger entries between 10:44 AM and 11:59 AM Eastern Time. We were first alerted to the issue at 11:33 AM Eastern Time.

A fix has now been deployed, and all affected payments will be automatically updated to Completed.

The issue was caused by a recent internal update to our payment tracking system, which distributes updates from upstream payment providers to our event listener. All other systems remained fully operational during this time.

If a customer completed a payment but did not receive a receipt email or their keys, these will be automatically delivered within the next 60 minutes as our system processes retries and clears pending updates.

Updated
Apr 5, 2026 at 3:29pm UTC

Root cause identified as a recent internal update to the payment tracking system (affecting event listener updates from upstream providers).

Created
Apr 5, 2026 at 3:00pm UTC

We are investigating an issue affecting payment pending status.