Back to overview
Resolved

Planned Infrastructure Maintenance

Jun 13, 2026 at 8:50pm UTC  –  Jun 14, 2026 at 10:50pm UTC
Affected services
API
Buyer Portal
Merchant Portal

Resolved
Jun 14, 2026 at 10:50pm UTC

Maintenance ended

Created
Jun 13, 2026 at 8:50pm UTC

We'll be performing a planned infrastructure upgrade this weekend (13 to 14 June) to support continued growth and improve performance.

No service interruptions are expected. However, you may notice slightly slower load times in the Merchant Portal and Customer Portal during the maintenance window. Checkout APIs, Billing APIs, and webhooks will remain fully operational.

This upgrade includes the rollout of additional edge regions to improve latency globally.